Child pages
  • Sakai 19 Upgrade Information
Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 8 Next »

About this page

This page is focused on upgrading from Sakai 12 to Sakai 19. It provides a link (below) to the Sakai 12 upgrade information that you will need if you are upgrading first to Sakai 12. Do that first and then come back here for the final steps to migrate to Sakai 19.

Select here to upgrade to Sakai 12, a prerequisite for upgrading to Sakai 19. If you are already on Sakai 12, you can ignore this link.

1.0 Database Conversion Scripts

Please run ALL the scripts from your original version to the version to which you are upgrading. There are two sets of database upgrade scripts, one for MySQL and one for Oracle. Use the appropriate scripts for your database type.

https://github.com/sakaiproject/sakai-reference/tree/master/docs/conversion

2.0 Post upgrade conversion scripts

There are no post upgrade scripts to run

3.0 Browser Compatibility

Sakai 12 is designed to work with modern browsers. Recommended browsers (those with the most QA testing effort against them) are Google Chrome, Safari, and Mozilla Firefox. Microsoft Edge and IE 11 should work fine. If you are upgrading from an earlier version of Sakai (pre-Sakai 11), please make sure that you don't have the property X-UA-Compatible:IE set, or it may make Microsoft IE 11 behave as though it is an earlier browser version and therefore not work. Sakai should work on most modern tablet and mobile devices. 

4.0 Upgrading the Sakai skin



  • No labels