Child pages
  • Browser Support

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

Sakai endeavors to support as many browser as possible, however, as with any complex web-based system, being able to support all web browsers is an extremely difficult task. The following operating system and browser combination were used during Quality Assurance (QA) testing for Sakai 2.5.4 and 2.6.0, and can be considered as a suggested list for supported browsers:

Windows XP, Vista

Internet Explorer 7
Firefox 2, Firefox 3

Mac OS X

Firefox 2, Firefox 3

While not widely tested as part of QA, Linux users can likely use Firefox 2 or 3 with Sakai successfully as well.

Users of the following browsers have reported some aspects of Sakai as not working correctly, such as the WYSIWYG editor. If you encounter reproducible problems with a specific browser - Sakai functionality combination, please file a bug report in Jira.

Browser

Notes

Windows Internet Explorer 8

19-Mar-2009 IE8 Official release comes out today.
29-Jan-2009 Out-of-the-box there are a number of problems with recent Sakai 2.x releases, however, they can be overcome by running in compatibility mode. If you don't turn on compatibility as part of installing and configuring IE8 initially, then you can use the Compatibility View icon in the tool bar or adjust settings under the Tools menu. You can also include this tag in pages: <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7">.

Mac Safari 4

add more folders fails, SAK-16025 (fixed)

Windows Internet Explorer 6

 

Windows Safari 3.1

no fck with sakai 2.5; add more folders fails, SAK-16025 (fixed)

Opera

no fck with sakai 2.5; can't create a folder in sakai 2.5.3, SAK-16400

Google Chrome

add more folders fails, SAK-16025 (fixed)

CLE is designed to work with modern browsers. You should be safe with the latest versions of Firefox (Mozilla), Safari (Apple), Chrome (Google), and with IE 9 (Microsoft Internet Explorer aka IE) and IE 8. Sakai CLE does not work with IE 7 and earlier nor with Firefox 10 and earlier.