Child pages
  • Maven installation (2.7)

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

The Apache Maven project management framework provides Sakai with "a set of build standards, artifact repository model and a software engine that manages and describes projects" (Better Builds, p. 22). As part of the installation process you will use Maven as a build tool in order to compile, test and deploy Sakai to a servlet container such as Apache Tomcat.

(warning) Maven 2.2.1 is the minimum version required for performing Sakai 2.7 builds.
(minus) Maven 3.0 is currently NOT compatible with Sakai 2.7.

...