Child pages
  • Indie release order - pre 2.9
Skip to end of metadata
Go to start of metadata

This document was accurate 2.6 - 2.8. The order for 2.9 changed and is on Indie release order - 2.9

The release order laid out below can be re-arranged as long as all snapshot dependencies have been eliminated prior to attempting a release using the Maven release plugin.

(minus) Be sure to update <parent> versions and <properties> noted below as necessary before performing release.
(minus) Samigo audio jar requires signing; activate -Pjarsign for both snapshot deployments and releases.

(warning) API cross-dependencies exist between courier and presence; consider re-packaging to simplify release. (SAK-21389)
(warning) API cross-dependencies exist between calendar and assignment; consider re-packaging to simplify release (SAK-21397)

Order

Project

CLE release

<parent>

<properties>

Notes

2.9.x Status

2.9.0-b02 Status

1

kernel

2.6+

 

 

 

(tick)

(tick)

2

sakai-basic-tool (purepoms)

2.6+

 

<sakai.kernel.version>

 

(grey lightbulb)

 

3

entitybroker

2.6+

sakai-basic-tool

 

 

(tick)

(tick)

4

sakai-standard-tool (purepoms)

2.6+

sakai-basic-tool

<sakai.entitybroker.version>

 

(grey lightbulb)

 

5

common

2.7+

sakai-standard-tool

 

 

(tick)

(tick)

6

sakai-commons-tool (purepom)

2.7+

sakai-standard-tool

<sakai.common.version>

 

(grey lightbulb)

 

7

edu-services

2.7+

sakai-commons-tool

 

 

(tick)

(tick)

8

sakai-edu-tool (purepoms)

2.7+

sakai-commons-tool

<sakai.edu-services.version>

 

(grey lightbulb)

 

9

content-review

2.8+

sakai-standard-tool

 

 

(tick)

(tick)

9

emailtemplateservice

2.7+

sakai-standard-tool

 

 

(tick)

(tick)

9

jsf

2.7+

sakai-standard-tool

 

 

(tick)

(tick)

9

2.9-jsf111

2.9+

sakai-standard-tool

 

(warning) calendar-summary-tool has a dependency on jsf111.

 

 

9

sakai-mock

2.7+

sakai-standard-tool

 

 

(tick)

(tick)

9

shortenedurl

2.8+

sakai-standard-tool

 

 

(tick)

(tick)

9

taggable

2.9+

sakai-standard-tool
jsf

 

 

(tick)

(tick)

9

search

2.7+

sakai-standard-tool

<sakai.entitybroker.version>

 

(tick)

(tick)

10

polls

2.6+

sakai-standard-tool

<sakai.entitybroker.version>, <sakai.ets.version>

 

(tick)

(tick)

10

reset-pass

2.8+

sakai-standard-tool

<sakai.entitybroker.version>, <sakai.emailtemplateservice.version>

 

(tick)

(tick)

10

sakai-presence-api

2.9+

sakai-basic-tool

 

(minus) API release due to cross dependencies between presence and courier.(SAK-21397)

 

 

11

courier

2.9+

sakai-standard-tool

<sakai.presence.version>

(warning) dependency on the presence-api.

(tick)

(tick)

12

velocity

2.9+

sakai-standard-tool

<sakai.courier.version>

 

(tick)

(tick)

13

presence

2.9+

sakai-common-tool

<sakai.courier.version>, <sakai.velocity.version>

(warning) dependencies on courier-api, courier-util.

(tick)

(tick)

14

portal

2.9+

sakai-standard-tool

<sakai.presence.version>

 

(tick)

(tick)

14

site

2.9+

sakai-standard-tool

<sakai.courier.version>, <sakai.velocity.version>

 

(tick)

(tick)

14

basiclti

2.7+

sakai-edu-tool

<sakai.entitybroker.version>, <sakai.velocity.groupId>, <sakai.velocity.version>

 

(tick)

(tick)

15

profile

2.7+

sakai-commons-tool

<sakai.jsf.version>

 

(tick)

(tick)

15

profile2

2.7+

sakai-commons-tool

<legacy.profile.api.version>, <entitybroker.version>, <sakai.common.version>, <sakai.ets.version>, <search-api.version>

(warning) <sakai.common.version> employed to define sakai-commons-assembly version; <entitybroker.version> employed to define entitybroker-utils version.

(tick)

(tick)

15

jobscheduler

2.7+

sakai-standard-tool

<sakai.jsf.version>

 

(tick)

(tick)

16

sitestats

2.7+

sakai-standard-tool

<sakai.sakai-mock.version>, <sakai.jobscheduler.version>

 

(tick)

(tick)

16

msgcntr

2.7+

sakai-edu-tool

<sakai.jsf.version>, <sakai.scheduler.version>, <sakai.search.version>

 

(tick)

(tick)

16

hybrid

2.8+

sakai-standard-tool

<sakai.msgcntr.version>

 

(tick)

(tick)

16

message

2.9+

sakai-standard-tool

<sakai.scheduler.version>, <sakai.velocity.version>

 

(tick)

(tick)

17

mailarchive

2.9+

sakai-standard-tool

<sakai.courier.version>, <sakai.message.version>, <sakai.search.version>, <sakai.site.version>, <sakai.velocity.version>

 

(tick)

(tick)

17

announcement

2.9+

sakai-standard-tool

<sakai.courier.version>, <sakai.entitybroker.version>, <sakai.message.version>, <sakai.scheduler.version>,<sakai.site.version>, <sakai.velocity.version>

 

(tick)

(tick)

18

mailsender

2.9+

sakai-standard-tool

<sakai.mailarchive.version>, <sakai.message.version>

 

(tick)

(tick)

19

sakai-calendar-api

2.9+

sakai-basic-tool

 

(minus) API release due to cross dependences between calendar and assignment. (SAK-21389)

 

 

20

calendar

2.9+

sakai-standard-tool

<sakai.assignment.version>, <sakai.jsf.version>, <sakai.jsf111.version>, <sakai.site.version>, <sakai.velocity.version>

(warning) jsf111 dependency may no longer be required.

(tick)

(tick)

21

assignment

2.9+

sakai-standard-tool

<sakai.announcement.version>, <sakai.calendar.version>, <sakai.contentreview.version>, <sakai.message.version>, <sakai.taggable.version, <sakai.velocity.version>

(warning) dependency on calendar-api.

(tick)

(tick)

22

samigo

2.7+

sakai-edu-tool

<sakai.calendar.version>, <sakai.common.version>, <sakai.edu-services.version>, <sakai.jsf.version>

(minus) -Pjarsign activation required. (Moving to a true indie release)

(tick)

(tick)

23

web-services

2.8+

sakai-standard-tool

<sakai.samigo.version>

(warning) dependency on samigo-qti

(tick)

(tick)

24

lessonbuilder

2.9+

sakai-edu-tool

<sakai.assignment.version>, <sakai.entitybroker.version>, <sakai.msgcntr.version>, <sakai.samigo.version>, <sakai.yaft.version>, <sakai.mneme.version>

(minus) dependencies on contrib Mneme and Yaft APIs.(LSNBLDR-32)

 

(tick)

  • No labels