Child pages
  • Browser Support
Skip to end of metadata
Go to start of metadata

Sakai 2.9 is designed to work with modern browsers. You should be safe with the latest versions of Firefox (Mozilla), Safari (Apple), Chrome (Google), and with IE 10, IE 9 (Microsoft Internet Explorer aka IE) and IE 8. Sakai CLE does not work with IE 7 and earlier nor with Firefox 10 and earlier.