Child pages
  • Page Composer 2.4.x Compatibility Notes
Skip to end of metadata
Go to start of metadata

Page Composer 2.4.x Compatibility

The Page Composer is compatible with Sakai 2.5.0 out of the box, but needs a small set of patches to work with 2.4.x, as well as a minor database conversion.

The JIRA issues that are related to this are:

David Haines has created some patch files for use with the CTools 2.4.x instance. Note that these should work fine, but are not guaranteed to work with other installations.

The simple database conversion SQL statements are included in /reference/trunk/docs/conversion/sakai_2_4_0-2_5_0_oracle_conversion.sql and /reference/trunk/docs/conversion/sakai_2_4_0-2_5_0_mysql_conversion.sql for Oracle and MySQL, respectively. They are reproduced here for convenience.

Oracle
alter TABLE metaobj_form_def add alternateCreateXslt varchar2(36) NULL;
alter TABLE metaobj_form_def add alternateViewXslt varchar2(36) NULL;
MySQL
alter TABLE metaobj_form_def add column alternateCreateXslt	varchar(36) NULL;
alter TABLE metaobj_form_def add column alternateViewXslt  	varchar(36) NULL;
  • No labels