Child pages
  • Java 1.6 Installation for 2.x
Skip to end of metadata
Go to start of metadata

Oracle's Sun Java SE 6, a.k.a Java 1.6, is the preferred version to use with the Sakai CLE, because it has been tested the most thoroughly. Java SE 7, a.k.a Java 1.7 should also be compatible. Certain files, such as *.jsp and *.jws, require compilation so downloading and attempting to use only the JDK, the JRE with only the run time environment (JRE 6.0 or JRE 7.0) will not suffice.  Mac OS X 10.6 (Snow Leopard) and later includes the full version of Java SE 6 so Mac users do not need to install Java.  If you find Sun's version and naming conventions confusing, see Sun Java SE Naming and Versions for an outline of their practices.

(minus) Oracle's Sun Java J2SE 5.0 (a.k.a Java 1.5) has completed the EOL process and is no longer supported. If are still running Java 1.5 please note that security vulnerabilities exist in JDK/JRE 5.0 updates 1.5.0_17 and earlier. Sun recommends that you install JDK/JRE 5.0 Update 18+ (the final update is JDK/JRE 5.0 Update 22).

Java 7

As of June 19, 2013, an issue has been reported with respect to Java 7 compatibility. The problem is in the Comparators and the workaround is to use the JVM property

-Djava.util.Arrays.useLegacyMergeSort=true

For details see - http://sakai-project-mail-list-archives.1343168.n2.nabble.com/Building-Sakai-Java-7-and-Sakai-comparators-tt7589944.html and KNL-1083 - Getting issue details... STATUS

 

To confirm that Java is both installed on your system and is the correct version for Sakai, run java -version from the command line:

java -version

If Java is installed, basic version and build information will be displayed:

java version "1.6.0_24"
Java(TM) SE Runtime Environment (build 1.6.0_24-b07-334-10M3326)
Java HotSpot(TM) 64-Bit Server VM (build 19.1-b02-334, mixed mode)

If Java is not installed or you are running the wrong version you can download the Java SE 6.0 JDK or the Java SE 7.0 JDK release from Oracle's Sun archive:

http://www.oracle.com/technetwork/java/javase/archive-139210.html

Install the JDK, typically in the /opt directory, i.e. /opt/java. Install the JRE in a different directory (usually the default directory, especially if running Windows) or you may experience run-time issues.

  • No labels