Child pages
  • Getting the Eclipse updater to work for minor releases
Skip to end of metadata
Go to start of metadata
  • By default, the Eclipse Update Manager will only update you to new service releases and not update you to a new minor release. In other words, if you have release 1.0.1 installed, it will update you to a 1.0.3 or 1.0.4 release, but it will not update you to a 1.1.0 or 1.2.0 release. You can change this in the Eclipse preferences.
  1. Click on Window -> Preferences...
  2. Click on the Install/Update option (don't open the Automatic Updates sub-area)
  3. Change the Valid updates preference to compatible
  4. Click OK to save the changes
  • Note: This is critical in Sakai development since we are often using rapidly evolving eclipse plugins and you will need the newest version in most cases
  • Note: This is adapted from http://subclipse.tigris.org/upgrade.html
  • No labels